« 2005年6月 | トップページ | 2005年8月 »

2005年7月

2005年7月31日 (日)

体調不良

今日、昼から少し外出したところ、帰宅してから体調が悪く倒れてます。
勉強しないとマズイのですが、なんともならず焦るばかり。

あと、三週間。
土日は2回しかない。

| | コメント (0) | トラックバック (0)

2005年7月30日 (土)

エコノミーで行く

sy05_4

来月の死ドニー行きであるが、実はフライトが、ビジネスなのかエコノミーなのか確定させていなかった。私はいろいろと優待などされるので、ビジネスで行っても、実はそんなに高いお金を払うこともない。

が、海外受験で合格したのは、エコノミーでのフライトの時ばかりである。
何の縁起が良い、などのパターンが確立されていない時には
「疲労防止のために行きはビジネス」
というスローガンを掲げていたが、今となっては
「合格したいならエコノミー」
である。

今日、JALさんから電話があって
「エコノミーの席が取れました」
とのこと。ビジネスをキャンセルして、エコノミーで確定させました。

7/11に必勝パターンを書いておいたが、他に加えることを含めて訂正である

1.成田空港のマックで何か食べる
2.移動はもちろんJALのエコノミークラスで
3.ホテルはTHE SEBEL
4.メシはさとうのご飯を中心に
5.セブンイレブンで、水とファンタオレンジと、定番のプリングルスを買う

これで神が降りてくると信じている

| | コメント (0) | トラックバック (0)

2005年7月29日 (金)

ラボ紹介、再度

Lab_hyodo

だんだんすごいことになってきた。
Routerを何台も投入している。
2500、捨てないで持っていて良かった。

貧乏なので、構成を変える時にWIC-1Tとか、あっちこっちに移動させないといけない。
それが面倒。

それと、ガレージ内が異常に暑い。

ガレージ兵頭は、リビングから直接入っていける。扉ひとつ隔てているだけ。
自分の部屋など無い(というかガレージが自分の部屋)ので、リビングで勉強しているが、ぶーん、、、という音が聞こえてくる。4500とか、何であんなにうるさいんだよ。

実は、Internetからアクセス可能にしている。
というのは、今まではSIerに勤務していたので、理解も得られて、会社の足元に機材を置いていた。で、自宅に帰ってからの勉強はモバイルで会社にアクセスしていた。土日は全て会社だったが。

今はそんなに会社の理解が得られないし、勉強しているとか、資格にチャレンジしているとか、ほとんど周囲に話していない。来月の渡豪は普通の休暇である。

だから自宅に機材をおいて、昼休みなどは会社から自宅環境にアクセスしている。
やっぱり不便。

でも自分の選んだ道なので、頑張ろう。

| | コメント (2) | トラックバック (0)

2005年7月28日 (木)

CCIE Security 受験者の方々へ

もしかしたらCCIE Security を受験予定の方がいらっしゃるかもしれませんが、これは必須という本を紹介しておきます。多分、海外受験するくらいの根性のある方であれば、既にご存知だとは思います。
R&Sにも使える内容も多々あります。

http://www.amazon.co.jp/exec/obidos/ASIN/1587051346/qid%3D1118631015/249-3110330-9941962

シドニーのプロクタ本人が書き下ろしたものです。
とても参考になります。
というか、無いと合格が厳しいと言っても過言ではないでしょう。
但し、この本が出版されてから、ラボ試験の内容に大きな変更があった(CCOで予告されていた)ので、その辺のアップデートがないと厳しいのかどうか判断できません。

実は本人から「今度本を出版するから読んでおけ」と言われて、その時点でアマゾンで予約受付中でした。
すぐに予約して、いざ発売されてから、なんと、アマゾンのミスで、私よりも後に予約を入れた方々に初ロットが渡ってしまい、とても焦りました。受験が控えていたので。
何でそれを知ったのかというと、友人が私の後で予約していて、先に入手したから。

アマゾンはそのミスを認めたのですがどうにもならないとのこと。私は
「間違って先に送付した人から取り上げてでもオレに渡せ」
と無理難題を吹っかけて粘りましたが、やっぱ、ダメでした。

受験の直前に何とか入手して、慌てて勉強しました。
ちなみに、その直後の試験で、やっぱ落ちましたけど(泣)

でも、その時に合格まであと一歩に迫ったので、次の受験に向けて最高のモチベーションアップになりました。
だって、それまでは合格の気配すらなく、どうにもならない状態でしたので。
毎日毎日、何度でも電車の中で読み返しました。

R&Sみたいに対策本が売っていたりパートナーさんで研修があったりしないので、孤独な闘いですから、こういうの、助かります。

| | コメント (0) | トラックバック (0)

SEBEL Hotel

ChatswoodのSEBELホテルでのことです。。
まぁ、ホテルのことなんて別に旅行でも一緒だし、特段にコメントするようなことでもないのですが、、

・入り口はとてもホテルと思えないような狭い間口です。
・エレベーターは、客室に上がる時にはICカードみたいなもので認証しないと動きません。
・バスタブがある部屋と無い部屋があるので、チェックインの際に「バスタブが必要だ」と伝えましょう。
・バスタブの栓は洗面台の下の扉の中においてあります。私は探してもどうしてもわからずにフロントに聞きました。「バスタブのドレインプラグはどこだ?」と質問して理解してもらえず途方に暮れました。
・セキュリティボックスを利用する時には、あらかじめフロントで申込書に記入してサインしないとダメです。
・部屋にはCDコンポがあるのでお気に入りの音楽の持ち込みを推奨します。
・キッチンなど、すべて揃っているのは以前に書いた通りです。電子レンジ有ります。
・洗濯もできます。
・アイロンもあります。
・インタネットアクセスはダイアルアップのみです。
・ホテル内にレストランはありません。
・Victor Street 沿いに立地してますが、Victoria Street,Victor Avenue などタクシーが間違います
ので地図の持参と、運転手さんへの念押しを推奨します。

要するに、コンドミニアムタイプの普通のホテルです。

| | コメント (0) | トラックバック (0)

2005年7月26日 (火)

GSRのバックプレーンがどうした!

いつも思うことがある。
自分はどういうエンジニアを目指しているのか。
別にエンジニアでなくてもいいんだけども、どういうキャリアを積んでどういう人生を歩んでいくのだろうか。

私の年齢では、「CCIEのダブルです」とか言っても、持っていること自体は何のプラスにもならない。
そういうスキルを会社から求められてないからだ。
まぁ、それにも関わらず、いまだに追求する理由は過去にも述べたので割愛しよう。

いつまでもお客さんの前で
「GSRのバックプレーンはホニャララで。。」
「3Way-Hand-Shakeの動作はホニャララで。。」
なんて言い続けて将来はあるだろうか。
何歳までそのスタイルで仕事をする?

脳は衰える。
今では、ググろうとしてGoogleを起動した瞬間に「何を検索するのか忘れた」という状態である。いつかは皆さんも衰える。きっと、衰えるときは来る。

私が経営者だったら、GSRのバックプレーンに詳しいくらいのエンジニアであれば、より安い賃金で雇える新人が出てくれば、あっさりと首をすげ替えるだろう。サラリーマンとは厳しいものである。じゃあCCIEを持っていれば大丈夫なのか?

もちろん、シスコのパートナーで勤務していれば、ゴールドだの何だのというパートナーの順列を決める争いのポイントに加算される。なので優遇されるのはある意味正解かもしれない。もちろん、CCNPや他のCQSの資格者も必要だが。

私が経営者であれば、持ってること、その事自体を評価はしないだろう。

実際に、取得しても給料が上がったりという人をあまり知らない。
奨励金をもらう程度だろうか。
「給料があがる」「もっと待遇がよくなるはず」と期待して頑張った人にとっては、その落差は大きく、がっかりしてしまうかもしれない。転職という道を選んでしまうかもしれない。

私はお客様の前で、何を必要とされているのだろうと、よく考えた。
(過去形なのは現在は職場環境が大きく違うからだ)

オレに対してGSRのバックプレーンの容量を即答することを望んでいるわけではないだろう。
お客様にとって厳しい経営競争を勝ち抜いていくために、例えばインフラをどのように構築していけばいいのか、などを正しく導いてあげることが求められていると思う。
しかし、信頼を得るためには、技術に対する深い造詣を忘れてはいけない。
難しいことを話さなくても、技術に対する深い造詣が沁み出るような語りがしたい。

が、製品/ソリューションを背負う以上は、30%くらいのウソは許して欲しい。
だって本当のことを言うと売れない製品もあるから(笑)

そこまでわかってもらって、お客様に信用してもらえれば、
「お客様の成功は自分の成功につながる」
と思えるだろう。

そんなエンジニアはなりたかった。
スタイルを変えないと優秀な新人が出てきたら自分の居場所がなくなるだろう。

今でも「こうありたい」と思う理想像に対して足りないものを多く感じる。というか、足りないものだらけだ。足りないことのひとつが、次のCCIEを目指す(取得する)ことで、この手にすることができるのであれば、、技術の神様、私はあなたにすべてを捧げましょう。

だが、もし、仮に、本当に仮の話であるが、次にまた転職するチャンスがあるのであれば、私は複数個のCCIEを所持していることを最大限にアピールするだろう(笑)
GSRのバックプレーンの容量を即答できることも、もちろんである。

技術の神様、そんなわがままな私をお許し下さい。

| | コメント (0) | トラックバック (0)

ベルギーの昼飯アップデート

隊長からアップデートが寄せられた。
何と、これ以上まずい昼飯はないと思われたベルギーの昼飯であるが、最近はチケットを受け取って食堂に行くようになったとのこと。今までは本当にまずかったので、進歩である。

が、それでもやっぱりまずいとのこと。。。
少しはマシになったくらいか。

SP派の方々はベルギーは関係ありませんが、Voiceを受験する人はきっとベルギーに行くと思いますので是非参考にして下さい。参考にしたからといって、まずい飯を回避できるわけではないですけどね。

なお、前の会社の同僚が6月にベルギーでVoiceに合格しています。
隊長もそれに続いて是非合格して欲しいものです。

| | コメント (2) | トラックバック (0)

2005年7月25日 (月)

2500のFlash

最近、2600シリーズがかなり安くなってきて、値ごろ感がある。
CCIEの勉強に使う程度であれば、1Ether(2610)でよければかなり安い。
私は一台だけ2611を持っているが、あとは2610か2620である。2Ether(FE)になると突然高価になるのでなかなか手が出ない。

で、足りないインタフェースはSerialで補っている。もちろんWIC-1Tもタダではないが、ひとつのインタフェースの単価としてはSerialの方が安いのではないだろうか。

だが、2500シリーズも捨てたものではないと思う。当然ながらすごく安くなっている。
私は wr の遅い、このシリーズが大好きである。私の一時代を支えてくれたと言っても過言ではないだろう(大袈裟すぎるか)。

勉強する人々であれば当然のように知っていることかもしれないが、2500のFlashは12Mという増強ができる。CCOでは「2500シリーズでは、ふたつのFlashバンクの容量を同じにすること」と書いてあるので、4,8,16Mのいずれかしか選択できないと思うだろうが、4+8=12Mという構成が可能である。

但し、確か記憶では、インタフェース側から見て、手前のバンクを8Mにしないといけなかったと思う。(定かではない)

sh flash で見たときに、12Mで見える場合と16Mで見える場合の2通りがあったと記憶するが、もちろん実際には12M以内のIOSしか格納することができない。

BootRomのバージョンにも依存したように思うので気をつけてください。

っていうか、いまどき、そんな変な構成をわざわざ作ることなんて無いだろうか。
IOSってどんどん大きくなるし。

| | コメント (0) | トラックバック (0)

バイクのエンジン

すいません。
ごく一部の方から「バイクのエンジンはどうなった?」との指摘がありました。
実はすでに組みあがってます。

どこまで改造ができるのか、クラスによって違うのでなんとも言えないところですが、私の出場するクラス(レース)は「何でもアリ」です。
普通、カムシャフトのタイミングはマークを一致させることでドンピシャのところで合わせるわけですが、より出力を求めようとすると、そのタイミングを変更することがあります。

上死点を正確に探して、そこからクランクが何度回ったところで、カムのリフト量をいくらにするのか、という整備を行う必要があって、簡単にはシリンダヘッドを載せることができません。

そこまでやったところで、受験対策のために活動を休止しています。

ちなみに我がガレージは先日末の引越し(単身赴任の荷物を引き上げた)のため、洗濯機やら冷蔵庫やらで身動きが取れない状況です。

その他のブログの内容も、試験まで一ヶ月を切った状態で、土日も含めてフル勉強体制で、更新が遅れると思います。気が付いたことがあれば更新を続けますので、見捨てずに読んであげてください。お願いします。

| | コメント (0) | トラックバック (0)

2005年7月23日 (土)

トラブルシューティング

4年くらい前まで、CCIEラボは2-Day試験だった。
一日目に、定められた以上の点を取らないと二日目に進めなかった。
二日目の午前中の時点で再び採点され、やっと二日目の午後に進めた。

だんだん人数が減っていく。残ると妙に晴れがましい気分にもなった。
逆に、一日目で落とされるとがっくりである。何と、採点結果を聞くのは二日目の朝なのである。

説明が面倒であるが、二日目に進めなくても、午前中だけは機材を触って帰って良い時代と、すぐに退出させられる時代があった。
すぐに退出させられると最悪である。だって、日本だったら会社に戻らないといけないから。
「あれ?」なんて、顔で会社で迎えられる。恥ずかしい。

二日目の午前を突破すると、いよいよトラブルシューティングである。
ほとんどの場合、ここまで来ると残っているのは一人である。

これはCCOにちゃんと書いてあったことなので、ここに書けるのだが、
「あなたがそれまでの時間に構築したネットワークを、プロクタが設定を変えたりケーブルの結線を変更したりして、意図的にトラブルを発生させます。それを解決してください」
って感じだったと思う。

私はトラブルシューティングは全然怖くなかった。だって、一日半に渡って入魂のconfigを叩き込んだRouter、Switchたちである。どこをどう変えられたって絶対にわかる。わからないはずがない。確認のポイントもわかっている。だから、トラブルシューティングに進んだ時点で合格だろう。

実際にはトラブルシューティングで落ちた人間がいることも知っているが、絶対の自信があったのは事実である。

で、死ドニーでの受験で。。。
http://homepage2.nifty.com/hyochin/sydney02.htm

プロクタから内容を聞かされた時に唖然とした。ここに書きたくて仕方ないが書くことはできない。だってCCOに書いてある事と違うよ、って思った。何度も話せない英語で、内容を確認した。
が、聞き間違いではなかった。

もう、「合格した」と思っていたので、狼狽した。
しかもとんでもないトラップに引っかかって時間を大幅に消費してしまった。

何度も英語で
「正確な残り時間を教えろ!」
と叫びながら問題を解決していった。
残り10分の時点で、まだ IP Reachability が保ててなかった。

どこに間違いがある?
どうしてneignborが上がらない?

「絶対の自信がある」って言っただろ、と突っ込まれるだろうが、許して欲しい。だって、、、
書きたくてもやはり内容に関することなので書くことができない。

わずか10分でどこまで解決できるか。
もうダメだろう。いくら何でもIP Reachability が保ててなかったら不合格だろう。

が、神が降りてきた。

土壇場のギリギリの時点で奇跡的に頭が冴えた。
次々にneighborが上がっていく。
全ての Reachability を確認する時間はないが、多分、いけてる。

残り30秒。間違いを発見したが、書き換えるべきか。途中で終了してしまったら、せっかく上がったneighborが落ちたままになるかもしれない。どうする?

勝負に出た。configを書き換えた。コマンドにして約10行くらいだっただろうか。
途中でneighborがダウンする。それは想定内だ。手が震えるがとにかく打ち込んでいく。
時間が足りるのか?
最後のコマンドを打ち終えた。
その時、後ろからプロクタが「終了だ。控え室で採点が終わるまで待機しろ。」と声をかけてきた。

neighborはあがるのか?
席を立ちながら画面を凝視し続けた。
何かメッセージがコンソールに出力された。
内容は見えなかった。

待ち時間はとても嫌だった。
何度も自分の点数を値踏みするが、合否ギリギリのような気がする。
トラブルシューティングまできて、不合格になるのか?
会社はまた受験させてくれるのだろうか。
もう一度、勉強するモチベーションを保つことができるのか。
これでダメだったら、もう意欲が復活できないかもしれない。

結果発表の際に、プロクタが
「Congratulation! You are CCIE!」
と言った瞬間を、決して忘れることができない。

トラブルシューティング。
もう二度と経験をしたくないと思うが、実は、またトラブルとのギリギリの勝負をやってみたいな、なーんて思ってもいる。
また、勝てるだろうか。

| | コメント (0) | トラックバック (0)

2005年7月22日 (金)

オレは負けないよ

負けず嫌いだと書いたことがある。

すると、foota-netさんもnetworkerさんも、負けずに「負けず嫌い」だと言う。
困ったものである。間違いなく、私が世界一の負けず嫌いなのだが。
負けず嫌い争いで、私が負けるはずがない。

レースを始めたのは大学生の頃。
「バリバリ伝説」(しげの秀一著)の主人公の巨摩郡(グン)に憧れて、彼がCB750FBで峠を走っていたから、その通りにCBを改造し峠を乗り回していた。猫峠や三瀬峠だ。

でかいナナハンを振り回して、それなりに早かった。(と思う)

ところが、グンがレースを始めた。だったら自分もやるしかない。
周囲も「そんなに早いんだったらレースやってみたら」とけしかける。

初めてサーキット走行に出かけた。西日本サーキット(現在の美祢サーキット)である。
自分より速いヤツは世の中にいないと思っていた。
が、速いヤツはたくさんいた。
自分が一番遅かった。

多くの人間は、ここで絶望する。
レースを続けるどころか、練習走行一回目で、周囲のあまりの速さに恐れおののき、二度とサーキットに来ることはない。

一部の、「負けてたまるか」という強く気持ちを持つ人間が残っていく。そういう人間で争うのがレースである。格闘技である。もちろん、私は「こいつら全員抜いてやる」と誓った。

大手企業に就職して、あまりの忙しさにレースができなくて会社を辞めたりした。親が泣いた。
まだ転職に世の中の理解が得られない頃だ。

私のような素人のレースでも年間に400万円使った。もちろん、当時の手取りを越えている。九州から鈴鹿まで遠征にも行った。腱鞘炎の手術もした。友人がサーキットで死んだりもした。弁当を買うお金がなくて、チーム員から弁当を半分分けてもらったこともある。

借金が膨らんで貸してくれるところがなくなったところでレースができなくなった。
気がついたら国際A級になっていた。

借金を返し終えてから、今でも草レースを走っている。
負けず嫌いだから、負けたくない。

で、バリバリ伝説のグンが、海岸線での、歩惟ちゃんを賭けてのゼロヨンレース。
話が長くなるので皆さんは第三巻を呼んで欲しいのだが、その時に言った言葉。

「オレは負けないよ。あんた、いいヤツだな」

私は臆病なのかもしれない。一度でも諦めることが怖いのである。ここで諦めたら次も諦めるかもしれない。本当は弱いヤツなのである。だから最後までやる。

CCIEに合格するなんて、小さなことかもしれない。だが、そんな小さなことすら諦めてしまうと、次のもっと大きな壁を越えることができないかもしれない。

陰口を叩かれても、最後までやる。陰口を叩いたやつら、おまえらが負けだ。
もちろんおまえらにはオレは負けないよ。ただし、おまえらはいいヤツではない。

| | コメント (3) | トラックバック (0)

2005年7月21日 (木)

Paymentしました

そろそろPaymentしないとヤバイので、ラボ代をカードで支払った。
いつものことながら、Paymentすると、なお一層に気合が入る。

ちなみに、28日を切るとPaymentしていた場合はお金は戻らない。
Paymentしていない場合は、予約が自動的にDropされる。

Voiceのラボが、Paymentしていたにも関わらず自動Dropされたことがあった。
「Dropされた」とシステムからメールが届いたのが夜の9時くらいだった。時差を計算するとブリュッセルは昼間である。英語をしゃべれないのに、「電話するしかない」と思って、目の前の電話で国際電話をかけた。タマラというCCIE Administratorの女性に必死に訴えた。必死になると何でもできると思った。

最後は理解してもらって、予約を復活してもらった。

今では「タマ」「タツ」とファーストネームで呼び合う「タマタツの仲」だ。
(全然ウソですよ!)

あー、もう戻れない。やるしかない。
飛行機もホテルも予約OK。
JALさん、今度も頼みますよー。

もう、試験までに土日が4回しかない。
もちろん一日も休まない。
平日の夜も寝るのは3時くらいか。
起床は6時なので少々きつい。

でも、オレは負けない。
今度は勝ちにいく。
前回、あと少しのところですり抜けた勝利を、今度こそ、手中にしてみせる。

また、神が降りてきてくれるだろう。

| | コメント (1) | トラックバック (0)

2005年7月19日 (火)

時間短縮に関する私なりのルール」

実際の案件ならいざ知らず、ラボ試験ではとにかく時間がない。
なのでいろいろと時間短縮の工夫をする。

これは、見やすいconfigを作るためでもあるのだが、、、

例えばroute-mapなどははじめから使う名前を決めておく。
policy-mapや、crypto-mapも同様だ。

決して、route-map test permit 10 みたいなつけ方をしてはいけない。
testじゃ、わからないだろ。test1とtest2の違いは何だ。
rest_xなどは最悪だ。センス無し。

私は必ず、そのroute-mapが持つ役割りを、その名前に最大限に盛り込む。

route-map OSPF_TO_RIP permit 10
route-map RIP_OUT permit 10
などなど

で、大事なことは事前に決めておくことである。もちろん何の問題が出るのかわからないのであるが、一回でも受験すれば何となくわかるだろう。

ラボ受験中に、route-mapの名前を考えるのに、10秒でも時間を使ったらあなたは負けである。
初めての名前だと、あとで確認の際にもまごつくことが予想される。

私のCCIE Security の際のように4時間も余らせる完勝であれば、まぁ、少々はどうでもいいが、経験上、いつも時間がない。最後は
「残り10分でconfig変更するかどうか」
の瀬戸際に立たされることもある。手が震えることもある。というか、私はいつも最後に手が震えている。余裕がないのかなー

ということで、自分なりのルールを決めておくことでの時間短縮を推奨する。

ちなみに、、、

policy-mapとcrypto-mapは、いつもP-MAPとC-MAPだ。
恥ずかしい。センス全く無し(爆)

| | コメント (0) | トラックバック (0)

海外での敗北

つい先日、友人が海外での敗北を味わった。
といっても彼はその経験は初めてではないのだが。

国内での敗北でも同様に悔しいことは悔しい。すごく落ち込む。
が、海外での敗北はとても重い。

初めての海外受験では、妙に晴れがましい気分もある。
オレも海外受験することになったのかと、酔ってしまう自分がいるかもしれない。
その場にいる自分を誇らしく思うかもしれない。

しかし現実は厳しい。
会社の経費で行くのであれば、「業務だから落ちても気にならないさ」などと言い切れる人もいるかもしれない。それはそれでいいだろう。が、私はそのように思えない。初回から二回目とだんだん重くなっていき、三回目などは、行く前から落ちたときの自分を考えてしまう。

同僚や周囲からは、間違いなく、絶対にこれだけは間違いないことであるが

「海外に受験に行けていいですね」

と言われる。絶対に言われる。何度も言われる。陰口もたたかれる。

「まさか、海外で三回目ともなれば落ちないだろう。」

などと根拠の無いことを思いつつ受験するが、実際には落ちてしまうこともある。
次に通る保証もない。なぜ落ちたのか。もちろん実力不足。まさに泥沼。

自費で行ったら楽なのか?
受験費用、渡航費用、宿泊費、その他もろもろで、時期にもよるが40万円ほどの出費は覚悟しなければならない。通るとわかっていれば惜しくもないかもしれないが、実際には合格率の低い試験なのだから、きっと落ちるだろう。合格までにいくら背負うことになるのか。長い人生でその出費を取り戻すことなどできるのか。

多分、損得勘定を気にするのであればきっと続かない。だって絶対に損をするから。何度も言うが、合格したからといって給料があがることもないし、それからの人生が保証されることもない。先があるなら行ってみようと思う気持ち、これをモチベーションと呼ぶのかもしれないが、その気持ちだけが自分を支えている。

私は幸か不幸か、もう実際に設定をしたり、もっと言えばネットワークの設計をすることもない。会社の人が見ているとまずいので少し弱めに書いておくが、基本的にハンコを押したり、部下の考えを聞いたり、社長への説明資料を書いたりするのが仕事である。だから、その立場でトリプルを狙うということ、それ自体が現職に直接役に立ったりすることは決してない。

では、どうして地獄の苦行を続けるのか?
そこにSPがあるからである。
エンジニアとして、先がある限り立ち止まることは許されない。

海外での敗北

皆さん、味わいたくないと思っているだろうか、きっと味わうことになる。なかなか表現できないから自分で経験してください。経験させてくれる貴重な場所が死ドニーにある。
そしてカルボナーラのペンネを味わってきてください。

| | コメント (0) | トラックバック (0)

2005年7月18日 (月)

ターミナルサーバが満員御礼

今、来月の死ドニー行きに向けて猛勉強中なのだが、いろいろとやっているうちに必要なデバイスが8台を超えてしまった。要するにターミナルサーバに収容できないのだ。

我が家は2509なのだ(泣)

私の場合、FRスイッチ&Backboneはターミナルサーバに収容しない。というか、設定を終えるとターミナルサーバのポートがもったいないので外してしまう。

・普通のMPLS Routerたち
・Switch
・カスタマーサイドのRouter
・VRF Lite を動かすRouter

などなど、往年の2500も持ち出して大変である。
我がガレージ兵頭は冷房が効くのであるが、機材の熱量で冷房効果も薄れている。

ご存知だと思うが、8ポートしかない2509でも、9ポート目のターミナルを使用することができる。AUXポートを利用すればいい。

CommServer#sh line
   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
     0 CTY              -    -      -    -    -      0       0     0/0       -
*    1 TTY   9600/9600  -    -      -    -    -      9       1     0/0       -
*    2 TTY   9600/9600  -    -      -    -    -      8      25  1780/5344    -
*    3 TTY   9600/9600  -    -      -    -    -     10       1     6/24      -
*    4 TTY   9600/9600  -    -      -    -    -      9       3  1778/5336    -
*    5 TTY   9600/9600  -    -      -    -    -     12      10     1/4       -
*    6 TTY   9600/9600  -    -      -    -    -      8     114     7/26      -
*    7 TTY   9600/9600  -    -      -    -    -      6      33   806/2427    -
*    8 TTY   9600/9600  -    -      -    -    -      7    3488  5708/17140   -
*    9 AUX   9600/9600  -    -      -    -    -      1       1     0/0       -
*   10 VTY              -    -      -    -    -     15       0     0/0       -
    11 VTY              -    -      -    -    -      4       0     0/0       -
    12 VTY              -    -      -    -    -      0       0     0/0       -
    13 VTY              -    -      -    -    -      0       0     0/0       -
    14 VTY              -    -      -    -    -      0       0     0/0       -

で見ればわかると思うがポート2009でリバースTelnetすればいい。
もちろん

line aux 0
exec-timeout 0 0
transport input telnet

相当の設定は必要であるが。

私はRSとSecurityを取得するまではターミナルサーバを持っていなかった。必要な都度、実際に”きし麺ケーブル”を差し替えて勉強していた。リモートで触る時にはひとつに普通にtelnetして、そこから内部に入り込んでいた。でも、PIXだけはTelnetできない(設定によりできることはできるが)ので、2500のAUXポートからリバースTelnetして触っていた。

ということで、今後ターミナルサーバを購入しようとしている方はぜひ2511を購入することをお奨めする。それなりに高価ではあるが。

今から買い換えるかなぁ。。。

| | コメント (2) | トラックバック (0)

2005年7月17日 (日)

OSPFでの認証設定

OSPFでの認証設定ですが、書き方が大きく二種類あると思います。
どう呼んだらいいのかわかりませんが、「古い書き方」「新しい書き方」と書くことにします。

古い書き方の場合は、
・router ospf xx の配下
・interface の配下
の両方に一行ずつ設定をしなければならなかったと思います。

新しい書き方の場合は、interfaceの配下にのみ二行を設定すれば済みます。
とても楽なのでこちらの方をお勧めします。

interface Serial0/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco

という感じ(md5の場合)で、お互いの対抗のinterfaceに設定を書けばいいのでわかりやすく混乱することがありません。

古い書き方の場合は、virtual-linkがあると理解に苦しみましたが

http://www.cisco.com/warp/public/104/27.html

新しい書き方では

router ospf 100
area 5 virtual-link 1.1.1.1 authentication message-digest
area 5 virtual-link 1.1.1.1 message-digest-key 1 md5 cisco

という感じで、両側に書けばいいのでとてもわかりやすいと思うのですが。
ずっと古い書き方でやってきたので切り替えには勇気が必要でしたが、とても楽になりました。

皆さんはどちらを使用してますでしょうか。

| | コメント (2) | トラックバック (0)

2005年7月16日 (土)

debug ip pac

あまりこんな失敗はしないと思うのだが、、、

お客様の稼動中のネットワークでどうしてもdebugしたい時がある。
が、そんなこと言ってもdebugを許してもらえるはずがない。
インパクトがないからちょっとくらいいいだろう、なんて甘いことを考えて

access-list 100 permit ip x.x.x.x ......
debug ip packet 100

みたいな感じで許可を得ずにdebugし問題解決。
ほっとして、バレないうちに早く消さなきゃ、と思って、ついついACLを先に消してしまうと終わりです。気付いたときにはコンソール入力不可状態でしょう。

って失敗をやるような、そんな時代もあります。

| | コメント (0) | トラックバック (0)

RIPにおけるスタティックの再配信

ちょっと変なことを考えてみた。

Lo0--R1(192.168.1.1)-----------(192.168.1.2)R2--Lo0

上記の構成でRIPを動作させる。
ここで、下記のstaticを設定し、RIPに再配信する。

<R1>
interface Loopback0
ip address 200.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
!
router rip
network 192.168.1.0
network 200.1.1.0

<R2>
interface Loopback0
ip address 200.2.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
!
router rip
network 192.168.1.0
network 200.2.2.0

もちろんRoutingTableは下記となる。

R1#sh ip route
C    200.1.1.0/24 is directly connected, Loopback0
R    200.2.2.0/24 [120/1] via 192.168.1.2, 00:00:21, FastEthernet0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0

R2#sh ip route
R    200.1.1.0/24 [120/1] via 192.168.1.1, 00:00:07, FastEthernet0/0
C    200.2.2.0/24 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, FastEthernet0/0」

ここで、下記のスタティックルートを設定し、RIPに再配信する。

ip route 100.1.1.0 255.255.255.0 192.168.1.2
!
router rip
redistribute static

要するにどこかへのスタティックルートを対抗のインタフェース向けにして、
それをRIPに再配信するのだが、これをR1は広報するだろうか。

R1#debug ip rip
RIP protocol debugging is on
R1#
*Mar  1 00:41:11.307: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.1.1)
*Mar  1 00:41:11.307: RIP: build update entries
*Mar  1 00:41:11.307:   network 200.1.1.0 metric 1

広報しなかった。
これは何のルールに引っかかって広報しないのだろうか。
だってイーサネットなんだから、192.168.1.0/24に第三のルータがいればそれ向けに広報しないの?
スプリットホライズンでもないし、広報しないというルールがわかんないです。

まぁ、何となく広報しそうにはないんだけど、どういう実装なのかそれがわからない。
R1が広報した結果、R2がRoutingTableに載せないというのであればそれは納得できるのだけど。

| | コメント (9) | トラックバック (0)

2005年7月15日 (金)

信念

人にできることには自分にもできる。
とてつもない努力が必要かもしれないが。

私には一般的な意味での才能はない。
それは身にしみてわかっている。
しかし、努力できるという才能だけは持っている。

だから、、、

人にできることは、きっと、自分にもできる。
それを信じていないと、とてもこんなことできない。

| | コメント (0) | トラックバック (0)

中曽根元首相が出ていた

きのう、報道ステーションに中曽根元首相が出演していた。中曽根と言えば忘れられないエピソードがある。これは実話であり、決してネタではない。

大学時代、私は福岡市に住んでいた。男ばかり3人でドライブに行こうということになり3号線を香椎から北九州方面に向かっていた。香椎を抜けた辺りから郊外となり安売りのガソリンスタンドが並ぶ地域があった。(現在もセルフなどに業態を変えているが存在する)

当時は、レーガン大統領と中曽根首相が仲が良いということで「ロンヤスの関係」などと呼ばれていた。つまり、お互いに「ロン」「ヤス」と、ファーストネームで呼び合う仲ということであろうか。テレビでも盛んに報道されていた。一緒にプールで泳いでいる映像を見た記憶もある。

私たちはガソリンスタンドが3店舗並んでいるところに差し掛かった。

一店目のガソリンスタンドで「バカ安!」という看板が出ていた。まぁ、そりゃ、安いと書くでしょうね。それがどうした。

二店目のガソリンスタンドで、また看板が出ていた。何て書いてあるかなーと思っていると、そこには「ペキ安!」と書かれていた。当時こういう表現が、はやっていたのは事実。大学生のバイトが隣に負けない看板を作ろうということで、ゲラゲラ笑いながら「ペキ」で行こう、と決めたのだろう。看板を作っている風景が目に浮かぶようであった。私たち3人も爆笑であった。

おっ、三店目が見えてきた。今度は何だろう。もう、「ペキ」以上の表現を使わないと消費者は納得しないぞ。だんだんと見えてきたその看板に、私たち3人は度肝を抜かれた。正直、これを書いた人間のセンスからいって、吉本興業などでもかなりの地位を確保できるくらいの笑いの能力を持っていると思った。看板に書かれていたのは、、、

「ロンヤス!」

である。笑いすぎて腹がよじれるかと思いました。

| | コメント (0) | トラックバック (0)

SEBEL Hotel

げげーっ!
SEBELから返事があって、Internetアクセスが「MODEM Dial UP のみ」とのこと。
いいかげんに環境を整備してくれよ。

ところで、このホテルのPBXの仕様なのだと思うが、0発信して、次のデジットを送ってもツー音が消えない。通常のモデムでは、その次のデジットを送るところで送出を止めてしまうはずである。

なので、「x3」という追加ATコマンドをダイアルアップで設定して下さい。ツー音を無視してデジットの送出を続けることができる。

じゃないと、Internetにつながらず、なぜつながらないのか調査ができないという憂き目にあってしまう。私は昔、少しだけモデムをよく触っていた時期がある、とっさに切り抜けることができた。あの天才ナカヤマでも「つながらないっすよ」と泣きを入れてきたくらいである。

が、モデムによってはx3無しでも問題なくつながることもある。
要は、詳しいなどと書いておきながら、よくわかってないということである。

| | コメント (0) | トラックバック (0)

2005年7月14日 (木)

辞書の持ち込み

もちろん、ラボには辞書を持ち込んでもいいですよー
英和も和英も。

確かに学科試験では使用できない。(その昔は学科の試験会場で貸してくれた)

新宿でも持ち込んでいいはずである。
だって語学の試験ではないのだから。
題意がわかるまで調べればいい。

一応、辞書に書き込み等がないかという、簡単なチェックは行われる。自分から申し出たほうがいいだろう。

おまえ、英語は得意だって言っただろ! と突っ込まれるのだろうか、念には念を入れて、ということである。ひとつの単語を読めないばかりに、題意を勘違いしたくない。

ただ、使用したことはほとんど無い。が、それでも持っていく。後悔したくないし。

| | コメント (0) | トラックバック (0)

前職の皆様

実は、私は7月1日に転職している。こういう世界だから特に珍しいことではないだろう。前職を、本当は辞めたくない気持ちが強かったのであるが、事情があった。ここで書くのはやめておこう。本当にお世話になった。とても良い人ばかりだった。

で、その企業は来週の火曜日にユーザカンファレンスを開催するのであるが、何と、私が今の会社を代表して出席することになった。要するに、私は現在シスコパートナーで働いていない。ユーザ企業、というのも少し変なのであるが、分類としてはそのようになるのであろう。前職の企業からはシスコ以外の機器を、ある会社を経由して購入している。このようなブログを立ち上げているが、シスコをあまり購入していない。よってシスコを仕事で触る機会は少ない。立場的にも会社でRouterなどを触ることはないだろう。まぁ、それはどうでもよいのだが。

二週間前まで働いていた企業に、ユーザとしてカンファレンスに参加するのはどうだろうか。とても恥ずかしい。辞めたことを知らない人もいるだろうし、受け付けなどに並んだらどう思われるのか。やっぱり恥ずかしい。

お手柔らかにお願いします。

| | コメント (2) | トラックバック (0)

隊長へ

今、友人がベルギーに行っている。普段、隊長と呼ばれている。旅行ではない。もちろん受験だ。彼はSPではない。だが、孤独に耐えて、ある高い領域に達しようとしているひとりである。頑張ってほしい。それ以上の言葉をかけてあげることはできないのだけれども。今は夜の1時くらいか。明日は一日ホテルで休養して金曜が試験だと聞いている。

朝までに作らないといけない提案で、DSPの搭載個数の判断がつかなくて、困り果てて、えらい深夜に隊長の携帯を鳴らしたことがありました。隊長は何も怒らず嫌みも言わず、ごく当たり前に答えてくれました。インフルエンザの予兆で苦しむ隊長を某社の検証ラボに引っ張り出したこともありました。おかげで翌日のお客様訪問時には私がインフルエンザにかかってましたが(涙)

今は会社は違うけれども、また教えてください。

朗報が聞けると嬉しいな♪

隊長へ
ヒマがあれば連絡下さい。
こんなところで書かないでメール出せばいいか。

| | コメント (0) | トラックバック (0)

受験地の選択

一度、foota-netさんのところに書き込みしたことがあるが、自分のところにきちんと書いてみよう。受験地にどこを選ぶか、ということである。これまた、あまりにもマニアックな内容で、万人ウケしませんな。。。
誰か読んで下さい(涙)

私は以下の観点で受験地を選択している。(というか、お勧めしたい)

・移動距離
・時差
・日本人をバカにしたり敵対視することはないか

例えばSecurityだったらサンノゼとシドニーだった。
(他にもあったかな? あまりに非現実的で選択肢に登らなかったかも)

SPだったら、シドニーとベルギーと北京。
Voiceだったらサンノゼとベルギー。

時差はとても大事だ。視察出張やミーティングなどの場合はそんなに重視しない。というか選択できない。皆さん、思い出して欲しい。サンノゼに行くとき、とてもきつくないだろうか。フライトにも寄るが基本的に朝に到着する。そこで寝てしまうとアウトだ。夜に寝れなくなる。で、翌日に試験でもあると大変だ。一日余裕を空けさせてもらったとしても、自然には時差ぼけが解消できない。

皆さん、受験で海外に行った事がなければこの苦しさはわからないだろう。カンファレンスでシスコに行くときなど本当に楽だ。が、受験で行くと地獄である。

私は眠剤などで一気に時差を解消するが、薬が合わない人もいるだろう。時差はとても重要な要素だ。なので私はサンノゼを推奨しない。サンノゼに行くくらいならベルギーに行く。時差は同じくらいだよ、って賢明な読者の方々はおっしゃるだろう。が、前に進む時差は苦しいが、後ろには楽である。(と思う)

ベルギー行きは、どのフライトを選択するかにも寄るのだが、憎っくきJALに乗ればアムステルダム経由でバスでベルギーに到着。夜の9時くらいに到着するが、夜なのである。とても疲れているが、なんと言っても夜なので時差に関係なくとにかく寝ることができる。で、起きたら時差ぼけ解消だ!

シドニーは最高だ。時差は一時間。フライトは9時間くらいだが、時差が無いのがとにかく楽だ。

北京もいいかもしれない。が、私は中国が苦手だ。ラボとの闘いはプロクタとの闘いの要素も含まれているが、うまくコミュニケーションできる自信がない。もちろん質問は英語でOKのはずだ。が、不安だ。何となく。。

とにかく、とてもきつい闘いなので受験地の選択は慎重に。遊ぶ気なんて少しも起きないから、観光気分などは一切持ち込まない方がいい。だって、直前までいろんなことをチェックしたいので、とてもとても街に出ようとか考える気は起きないだろう。(ガレージ兵頭のCCIE Voice 一回目は特別である。あまり突っ込まないように。)

もし、自費での参戦で、せっかくだから翌日くらいは遊んで帰ろうと思っているのであれば否定はしない。そんな余裕があるのなら、どうぞ。私なら落ちることを予測して、一刻も早く勉強に復帰したい。早く日本に戻ってラボで確認をしたい。そう思うから。翌日にすぐ帰る。甘い闘いではないのである。

networkerさんが過去に書いてくれていたが、本当に孤独である。よく言い表してくれていたと思う。ありがとうございました。あんなに的確な表現に出会ったのははじめてでした。だから書き込みさせてもらいました。

が、ひとつ間違いがあった。私は観光でオーストラリアに行ったことがある(笑)。

さぁ、シドニーに行きましょう。豪州観光協会の回し者ではないが。
もちろん、シドニーで受験している日本人は私だけではないことはよく知っている。

SEBEL Hotel に宿泊し、水とプリングルスを買いにセブンイレブンに行って欲しい。他に買いたいものがあれば目の前のショッピングセンターに行って欲しい。シスコまで歩いて受験に向かって欲しい。
その刹那に、取り返しのつかない領域に踏み込んだ自分に気づくはずである。
もう、戻ることはできない。
先に進むだけである。
さぁ、今日も今から頑張ろう。かなり眠いのだが。

| | コメント (0) | トラックバック (0)

2005年7月13日 (水)

Rconnected

何の参考にもならないので、これも読み飛ばしてください。
でも、何か意見があったり知っている方は是非とも教えてください。

"sho ip eigrp topo"の出力結果で、"via Rconnected"というのがあります。(以下)

P 192.168.201.254/32, 1 successors, FD is 2178560
         via Rconnected (2178560/0)

どうもPPPの対抗リンクのアドレスなのですが、Rconnectedって何ですか?
すぐにCCOをフル検索してもムダです。それくらいやってます。
気にしなくてもいいレベルですが、気にする人は気にするもので。。

| | コメント (6) | トラックバック (1)

死ドニー行きサポート

map

死ドニー(networkerさんが使用してして気に入ってしまった)へのサポートシリーズ。オーストラリアでは下記でmapをお調べ下さい。
http://www.whereis.com/whereis/home.jsp
すいません。地図の真ん中の黒いところがChatswoodの駅です。空港からChatswoodまでは下記参照下さい。
http://www.cityrail.info/index.jsp
InternationalからCentralに行き、そこで乗り換える。そこまで15分くらい。
CentralからChatswoodまで25分くらい。
駅員さんは皆親切だし、日本と違ってあちこちに駅員さんがいるので困れば聞けばいい。全然大丈夫。但し、International駅は通勤ルートの途中にあるので朝の時間帯は、乗り込む時には満員電車と化している。でかいスーツケースを持って乗り込むにはとてもつらいので注意してください。JAL便など、朝到着の場合は空港で少々時間をつぶすか、タクシー利用が無難です。タクシーで50~60AUDくらい。Railだと15AUDくらいだったと思います。

こんなこと、誰が喜んで読むのだろう。マニアック過ぎるか。反省。

| | コメント (2) | トラックバック (0)

資格にこだわる?

昔、「どうしてそんなに資格にこだわるんですか?」と言われたことがある。
Securityに挑戦する、と宣言した頃だ。
正直、思いもよらないことを言われてびっくりした。
あぁ、そう思われるんだな、と。

確かにCCNP,CCDPを取得した頃は、資格取得にこだわった、というかプライドを持っていたことがあった。当時、情報はCCOと英語の教材しかなく、ユーザ企業にいた私はCCOでの調べ方もわからない。英語のACRC(当時はRoutingのことをこう呼んだ)の教材を前にして、仕事が終わってから日が変わるまで会社で勉強を続けた。一日に5ページくらいしか読み進まなかった。英語自体は得意だったが、内容を理解できない。とてもつらかった。当時、英語試験は東京でしか受けれなかった。当時は北九州に住んでいたので、たまの出張の際に受験する。落ちると呆然とした。次に受験できるのは一体いつだ?

(ちなみに私はずっと九州に住んでいるのではありません)

そんなことを続けて当時は珍しかったCCNP,CCDPを取得した。喜んでロゴを名刺に入れた。

その後、さらに高いステージを目指した。確かに資格にこだわったのかもしれない。しかし、そのステージは単に資格にこだわる程度で超えれるものではない。いつしか資格がどうのこうのという気持ちは消えていた。もっと上があるなら登ってやろうと。苦手なことがあるなら勉強してやろうと。その一心。

そういう時に言われた言葉。
高みを目指そうとすると、きっとついて回る言葉。
なかなか飲み込むことができなかった言葉だったが、いろいろと考えるきっかけになった。上を目指す気持ちが周囲からは自然に見えなかったのだろう。正直な感想を言ってもらって感謝している。ありがとうございました。その、言ってくれた人もCCIE。

さぁ、これから勉強タイムである。
自然体で頑張るぞ。
もちろん、資格そのものにこだわってはいない。
ただ、そこにSPがあるから(笑)

| | コメント (0) | トラックバック (0)

2005年7月12日 (火)

ITおやじからの苦言

例えばの例である。AutoInstallという機能をご存知だろうか。単にCCOで紹介されているFeatureのことである。別に大した機能ではなく、普通にCCOに記述がある。私は受講したことがないのだが、CCIE対策を銘打っているセミナーでも紹介されるらしい。新規ルータが接続される先の既存ルータは下記configみたいになると思う。私はIOS11.3の頃(多分)に検証した。
helper-addressを書くというテクニックで語られる。

interface Serial0/1
ip address 192.168.1.1 255.255.255.0
ip helper-address 200.200.200.1
encapsulation frame-relay
frame-relay map ip 192.168.1.2 300 broadcast
frame-relay lmi-type ansi

新規routerはまずIPアドレスを取得しようとする。Framerelayインタフェースの場合、まず最初にHDLCで接続しようとして失敗し、次にencap framerelayで接続する。ここで、対向のインタフェースのframerelay mapから自分のインタフェースのIPアドレスを取得する。encap HDLC の場合は、192.168.1.1の様に末尾のアドレスを1にしておくと新しいrouterのIPアドレスは92.168.1.2となる。次にTFTPでnetwork-confgファイルから自分のhostnameを解決しようとする・・・
ここらで止めておこう。

設定そのものを紹介しようとしているわけではない。皆さんもほとんどの方が「そんなの知ってる。helperでしょ。」と言うだろう。
本当ですか?
本当に動作を知ってますか?
実はCCOの通りに動作しない個所があることをご存知ですか?
現在のCCOでは知らないが11.3の頃は明らかに記述に間違いがあった。私は丸2日かかってその間違いを発見した。苦労したから誰にも教えない(笑)

実際にTFTPサーバを立てて、network-confgファイルとconfigファイルを準備してこのAutoInstallを実際に動作させたことのある方は何%いるだろうか。この精度で検証をしない人は合格できない。神になるために試練を、単にconfigのテクニックだけで超えれるはずはない。

もし、(例えば、であるが)これにNATなどが絡んだネットワークだったら?
単なるテクニックでしかこのFeatureを知らない人には、こういうところを越えられない。

というITおやじからの苦言である。私には頭の冴えがないので地道にやっていかないと若い連中には勝てない。それが羨ましいだけか。また、勉強勉強。。

| | コメント (2) | トラックバック (0)

PIXを経由するBGP認証

意味の無い設定シリーズ。読み飛ばして下さい。

R1-----(inside)PIX(outside)-----R2

上記の構成で、R1とR2はBGPのPeerに認証を設定できるであろうか。
答えは「できる」である。
但し、簡単にはできない。構成上の制約もある。PIXでNATすると認証に失敗する。
R1のPIX側のアドレスを1.1.1.1とすると

static (inside,outside) 1.1.1.1 1.1.1.1.1 norandomseq

のようにしなければならない。NATしてしまうとBad-Authenticationというエラーを吐く。(PIXは6.2を使用してます)

| | コメント (2) | トラックバック (0)

ラボ中のコミュニケーション

私は英会話は苦手である。得意なことは得意だとはっきり主張できる性格なので言うが、英語は得意である。読み書きで苦労したことは、受験時代を含めて全然無い。人よりも一生懸命に勉強したからだと思う。が、英会話はダメだ。

検疫検査の時に
「フォーダイズ?」
とオーストラリア英語で聞かれて、大豆の持ち込みを疑われていると真剣に思ったくらいである。この話はネタではない。
http://homepage2.nifty.com/hyochin/sydney03.htm

そんな私が新宿ラボの予約が取れない状況に業を煮やし海外受験をそそのかされた。当時の部長も行って来いと言う。とても悩んだ。半年後の新宿で必勝体制で受ける方が良いのか、でも、半年も待つ事はできない。

そこに朗報アリ。天才ナカヤマが一緒に行ってくれることになった。彼はTOEIC980点。それでも一番得意な外国語はフランス語だという真の天才だ。今は違う会社に勤めるが、今でもRoutingに悩んだら彼に相談する。彼の言うことなら信じる。全幅の信頼を置いている。

これで受験会場まで辿り着くまでは問題無しとなった。あとはプロクタとの会話である。が、よく考えて欲しい。普段から読んでいるドキュメントは全て英語のはずである。何も心配は無い。適当にOSPF、neighbor、negociationなど、いつも読み書きしている単語を適当に並べれば絶対に通じる。恥ずかしいなどと思ってはならない。そんなこと、誰も気にしていない。自分の質問に対してある程度は回答の予約ができているはずだ。だから理解できる。

私は8時間のラボ中に、10回は質問をする。だって、設問の書き方が曖昧なんだから質問しないと不安だ。勝手な思い込みも防ぐことができる。今まで何度も解答に直結するヒントをもらった。どうしても解答がわからず、何か引き出そうと思って「これはミスプリントだ。解答が無い」とも言ったことがある。まったく失礼な話である。が、ミスプリントでは無い、とプロクタが力強く答えたことでモチベーションが高まり、解答に至ったこともある。日本でのラボにも共通したことであるが、とにかく質問すべし。

プロクタとは何とかコミュニケーションできたが、でも天才ナカヤマに比べると雲泥の差。当時のTOEICは480点くらいだったと思う。こりゃいかんと思ってTOEICの勉強をして650点まで取れるようになった。もともと苦手なので限界である。もう勘弁して。その程度の会話能力で全然問題ないっす。TOEICの点数まで公開して、まったく恥ずかしい。

| | コメント (0) | トラックバック (0)

2005年7月11日 (月)

各受験地の昼食

各ラボ受験会場での昼飯の話題である。
試験時間は厳密に8時間を計測されているので、昼食前はプロクタが全員に声をかけて一斉に終了する。同じように昼食後の開始も一斉である。早く食べてもゆっくり食べてもラボ時間は8時間である。プロクタが「もうラボに戻るか?」と質問すると、大概の受験者は「早く戻りたい」と言う。早く戻っても時間を長くすることはできないのだが皆さん焦っているのであろう。焦る気持ちについては下記参照下さい。
http://homepage2.nifty.com/hyochin/sydney08.htm

<新宿>
弁当が出る。選択の余地はない。うまいともまずいとも思わなかったが、世界を股にかけるプロの受験家(笑)となった現在では、この弁当は高い水準にあることを確認できている。これをまずいと思ったら海外受験に行くことはできないだろう。

<シドニー>
一回のカフェテリアみたいなところでプロクタを囲んで食べる。シスコのInformationで受験の受付をする際に、食べ物と飲み物を選択することができる。メニューは「ビーフバーガー」「チキンバーガー」など数種類あるが、はっきり言って美味しくない。私は試行錯誤の結果「ペンネのカルボナーラ」がギリギリ食するレベルであると思う。受付の際に英語でまごまごしているうちに焦って適当なものを注文しないようにしよう。こういうところから受験は始まっているのだ。

<ベルギー>
ラボ会場の隣に休憩室みたいなところがあって、そこにサンドイッチというかハンバーガーというか、まずいパンにまずい食材を挟んだものが適当においてある。それを自由に取って食べる形式である。昨年のサンノゼ出張の際に似たものを食べた。とてもまずかったが、それと同じである。私にはまずくて食えない。が、このまずいサンドイッチを2つ食べた日本人の受験者がいたとの情報がある。

<サンノゼ>
10ドルのクーポンを渡されるので、それで食堂で適当に食べるものをチョイスして払う形式。オーバーした分は自費で払えば問題ない。私はうかつにもサンノゼでの受験経験はないが、アメリカンの食事なので期待はしない方がいいのだろう。なお、ベルギーでまずいサンドイッチを2つ食べた日本人の受験者は、英語が堪能なはずなのに、クーポンの使用方法がよくわからずに、このサンノゼの地でソフトクリームだけを食べたという情報がある。

昼食時に、もちろん試験内容に関する話をすることはできない。が、特に海外では受験者の皆さんは根が陽気なのだろう、試験以外のことを話しかけてくることが多い。シドニーでの受験者はほとんどが豪州以外から来ている。アジア圏が多いだろうか。皆さん、英語が堪能である。初期の頃は、何よりもこの昼食時の会話が嫌で嫌で仕方なかった。試験対策よりも昼食対策に時間を割いたくらいだ(ウソ)。

| | コメント (2) | トラックバック (0)

PIXを経由するeBGP

PIXを経由するeBGPなんて何の意味があるのかどうか知らないが検証してみた。
読み飛ばして下さい。

<R1>
200.1.1.254
|
200.1.1.1(outside)
<PIX>
192.168.1.1(inside)
|
192.168.1.254 => 200.1.1.100でoutsideに公開
<R2>

***************各Routerで設定すること**************
<R1>
router bgp 100
no synchronization
network 150.1.1.0 mask 255.255.255.0
network 151.1.1.0 mask 255.255.255.0
network 210.1.1.0
neighbor 200.1.1.100 remote-as 200
neighbor 200.1.1.100 ebgp-multihop 2
neighbor 200.1.1.100 route-map SETNH in
!
route-map SETNH permit 10
set ip next-hop 200.1.1.100

<R2>
router bgp 200
no synchronization
network 135.1.1.0 mask 255.255.255.0
network 135.1.2.0 mask 255.255.255.0
network 199.1.1.0
neighbor 200.1.1.254 remote-as 100
neighbor 200.1.1.254 ebgp-multihop 2

<PIX>
access-list 100 permit tcp any any eq bgp
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 200.1.1.100 192.168.1.254 netmask 255.255.255.255 0 0
access-group 100 in interface outside
***************各Routerで設定すること**************

R1にてneighbor 200.1.1.100 route-map SETNH inを書かなければ<R1>はNextHopを解決できない(NextHopがPIXのInsideになるため)ため、RoutingTableに反映されない。
ebgp-multihopは、<R1>からみるとPeer先は同じネットワークなので不必要に思われるが、Debugをしてみるとnext-hopに到達できないのでRouteをDENYしているように見える。

02:08:10: BGP: 200.1.1.100 rcv UPDATE w/ attr: nexthop 192.168.1.254, origin i,
metric 0, path 200
02:08:10: BGP: 200.1.1.100 rcv UPDATE about 135.1.1.0/24 -- DENIED due to: non-c
onnected next-hop;
02:08:10: BGP: 200.1.1.100 rcv UPDATE about 135.1.2.0/24 -- DENIED due to: non-c
onnected next-hop;
02:08:10: BGP: 200.1.1.100 rcv UPDATE about 199.1.1.0/24 -- DENIED due to: non-c
onnected next-hop;

R1#sh ip bgp
   Network          Next Hop            Metric LocPrf Weight Path
*> 135.1.1.0/24     200.1.1.100              0             0 200 i
*> 135.1.2.0/24     200.1.1.100              0             0 200 i
*> 150.1.1.0/24     0.0.0.0                  0         32768 i
*> 151.1.1.0/24     0.0.0.0                  0         32768 i
*> 199.1.1.0        200.1.1.100              0             0 200 i
*> 210.1.1.0        0.0.0.0                  0         32768 i
R1#sh ip route
Gateway of last resort is 200.1.1.1 to network 0.0.0.0
C    200.1.1.0/24 is directly connected, Ethernet1
B    199.1.1.0/24 [20/0] via 200.1.1.100, 00:01:20
C    210.1.1.0/24 is directly connected, Loopback2
     151.1.0.0/24 is subnetted, 1 subnets
C       151.1.1.0 is directly connected, Loopback1
     150.1.0.0/24 is subnetted, 1 subnets
C       150.1.1.0 is directly connected, Loopback0
     135.1.0.0/24 is subnetted, 2 subnets
B       135.1.2.0 [20/0] via 200.1.1.100, 00:01:20
B       135.1.1.0 [20/0] via 200.1.1.100, 00:01:20
R*   0.0.0.0/0 [120/1] via 200.1.1.1, 00:00:18, Ethernet1

R2#sh ip bgp
   Network          Next Hop            Metric LocPrf Weight Path
*> 135.1.1.0/24     0.0.0.0                  0         32768 i
*> 135.1.2.0/24     0.0.0.0                  0         32768 i
*> 150.1.1.0/24     200.1.1.254              0             0 100 i
*> 151.1.1.0/24     200.1.1.254              0             0 100 i
*> 199.1.1.0        0.0.0.0                  0         32768 i
*> 210.1.1.0        200.1.1.254              0             0 100 i
R2#sh ip route
C    199.1.1.0/24 is directly connected, Loopback2
C    192.168.1.0/24 is directly connected, Ethernet1
B    210.1.1.0/24 [20/0] via 200.1.1.254, 00:00:51
     151.1.0.0/24 is subnetted, 1 subnets
B       151.1.1.0 [20/0] via 200.1.1.254, 00:00:51
     150.1.0.0/24 is subnetted, 1 subnets
B       150.1.1.0 [20/0] via 200.1.1.254, 00:00:51
     135.1.0.0/24 is subnetted, 2 subnets
C       135.1.2.0 is directly connected, Loopback1
C       135.1.1.0 is directly connected, Loopback0
R*   0.0.0.0/0 [120/1] via 192.168.1.1, 00:00:12, Ethernet1

| | コメント (0) | トラックバック (0)

ラボ予約(ホテル編)

私はCCIEラボのオンライン予約システムで、新宿に予約を入れたことがない。実は新宿で受験したことがあるのだがその時はまだメールベースでの担当者とのやり取りだった。

なのでもしかしたら皆さん当たり前に知っていることなのかもしれないが、まぁ、書いてみよう。海外のラボ予約を入れるとccie@cisco.comからメールが来る。「予約完了」を知らせる内容で、その中にRecommendのホテル一覧が載っている。通常、5つくらいのホテルがRecommendされている。シドニーの受験会場はシスコオーストラリアでChatswoodという街である。シスコがrecommendしているホテルでChatswoodのものはひとつだけである。あとは少々距離が離れていると思う。
http://www.mirvachotels.com.au/hotel_detail.asp?hotel=9
季節にもよるが、195AUDのレートである。日本円にすると、、、面倒なのでご自分で計算してください。

シドニーのダウンタウンからは少々距離がある。電車で25分くらい。タクシーでもそれくらいかかる。なのでこのTHE SABEL が一番良いように思う。シスコまで歩いて5分くらいだ。が、はっきり行って何もない街である。期待しないほうがよい。ベルギーの受験会場もひどいが、ここも何もない。

ガレージ兵頭(のメインHPの方)の賢明なる読者であればこのホテルの概要はわかっているだろう。アパートメントタイプで生活に必要なものは全て揃っている。無いのはハシくらいだ。逆にホテル内にレストランが無い。目の前にバカでかいショッピングモールがあるのでそこで何でも買える。

ベッドルーム、リビングルーム、キッチン、ランドリー、バスルームがそれぞれあり、とても広い部屋である。2ベッドの部屋なんかになると一回も中を見ていない部屋があるくらいである。

今、確認中であるが、一年前まではダイアルアップでしかインタネットアクセスできなかった。さすがに今はLANアクセスくらいできるだろうと思うが、ホテルに問い合わせ中なのでまだレポートする。

私はさとうのご飯を持ち込み、それを電子レンジで暖めて、あとはカップ麺やふりかけなどで食べている。

一度でもオーストラリアに行ったことがあるならばご存知かもしれないが、食料の持ち込みには本当に厳しい国なのでちゃんと申告しなければダメである。申告すれば何ということはないので絶対に正直に申告してください。なお、ふりかけに卵が含まれている場合には持ち込みできない。でも現地で調達可能である。

前回、JALのクーポンを持っていることからダウンタウンに宿泊したが、それがダメだったのかもしれない。私は縁起などにはこだわるタイプである。カツカレーを食べたりと、いろいろこだわるポイントがあるが、今のところ少なくとも下記が「必勝パターン」である。

1.成田空港のマックで何か食べる
2.移動はもちろんJALで
3.ホテルはTHE SABEL
4.メシはさとうのご飯を中心に

そういえば、前回のSPの試験では、上記の必勝パターンのうち2しか満たしていない。こりゃダメだ。ということで、今回はTHE SABEL にさとうのご飯を持ち込むことにしよう。

あ、熱くなってこんなに書いてしまった。
読者の皆さん、ごめんなさい。もう少し身になることを書くようにします。

| | コメント (0) | トラックバック (0)

2005年7月10日 (日)

スピードマスター

omega ガレージ兵頭のメインHPの方にレポートがあるのだが、私はR&Sに合格した際にスピードマスターを購入した。特に時計が趣味というわけではないが、機械ものは大好きである。バイクの整備を自分でやることからもわかってもらえると思う。だからオートマチックの時計が欲しかったのである。

特に大事にしているということもなく、普通の時計として使用している。以前、道端ですっころんだ際に傷が入っていさえする。でも、この時計を見ると、いつでも気持ちが高揚してくる。負けるものかという気になってくる。この時計に、私は初心を忘れずに日々精進に励むことを誓ったのである。

ダブルを達成した際に、二個目のオメガを買おうと思っていた。が、買わなかった。正確には買えなかったのである。金がなかった。時計を買うくらいの金の余裕はあったが、合格までに注ぎ込んだお金のあまりの大きさに、お金を使うことにびびってしまったのである。

私は釣りをするので、今度は防水仕様かな、ということで、オメガのアプネア(ジャックマイヨール)が欲しかった。7個のインジケーターが一分毎に赤くなっていくモデルである。往復で14分を正確に刻むことができる。潜水の世界で14分がどういう意味を持つのか全然しらない。IPSECの設定を14分以内に設定しなければいけない状況などあれば役に立つか(笑)。それとも提案書を読む時間を計測するか。

懇意にさせて頂いているnetworkerさんも書いていたが、CCIEに合格したからといって収入が上がることもなく、人生が保証されることもない。それは幻想である。ただ、それを”真の意味”で乗り越えることによって間違いなく次の世界に進むことができる。結果的により良い人生が待っているかもしれない。その程度である。

R&Sに合格した際に、「これで人生も安泰かな」と正直思った。恥ずかしいことであるがそう思った。が、3日経過した時点で怖くなった。世の中に自分(と同じ世界)を目指してくるエンジニアたちの何と多いことか。今にとどまっていたら、いつかは追いつかれる。とても怖かった。まだまだ知らないことだらけである。

じゃあ、知らないことを勉強してみよう。方法は、またCCIEに挑戦することが適切だと思った。ターゲットはSecurityだった。

で、ふたつめを獲得した。それでもやっぱり怖かった。まだ知らないことがある。MPLSのコアなんて何も知らない。じゃあ、また勉強してみようか。まだ先の世界が待っているように感じた。

SPに合格できるだろうか。それはわからないが、きっと合格するまでずっと挑戦するだろう。何年もかかるかもしれない。その時までアプネアが販売されているといいのだが。

| | コメント (0) | トラックバック (0)

2005年7月 9日 (土)

受験日決定

sy05_kaimono 矢継ぎ早の更新。受験日決定である。8/22に予約した。会社が出張に行かせてくれるわけではないので、「夏期休日」という会社の制度を利用して、これまた自費で行ってくることになる。休みを最小限とするためには月曜か金曜に受験せねばならず、福岡から成田経由で行こうとすると、金曜日の受験の場合には水曜日の夕方から移動しなければならないので、受験に行けるとすると、試験日は月曜日しかないのである。

受けると決まったら私の場合は睡眠時間は3時間くらいに削る。会社で勉強させてくれるわけでもないので全て就業後と土日での勉強になってしまう。睡眠不足でフラフラになりながら、でも寝るヒマがない状態を、私は数ヶ月も続ける精神力を持っていない。せいぜい2ヶ月が限界である。この期間、夜には発狂もするし、深夜に勉強しながら不安から涙が止まらないこともある。車を運転していたらOSPFがぐるぐる回りだして、訳がわからなくて大声を出したら夢だった、なんてしょっちゅうである。EIGRPが回ることもある(笑)。

R&Sの時も死にかけたが、特にCCIE Security に挑戦を続けた約一年間は死にそうだった。

たまには息抜きでもした方が良い、などという人は決して合格しない。そんなに低いハードルではないからだ。神になるための試練がそんなに甘いはずはない。

そこまで行かないと見えない世界があるなら行ってみたい。でも、もし、その世界に行くことができたら、きっとその先を目指すだろう。資格がどうのこうの、とか、そんなことを気にしてはいない。単に資格試験を利用して先に進もうとしているだけである。

人生を賭けた勝負に絶対に勝ってやる。オレは負けない。

で、受験地は?
もちろん、高みを目指すエンジニアの死に場所、シドニーである。

| | コメント (5) | トラックバック (0)

2005年7月 8日 (金)

ガレージ兵頭という名前

いろいろな方々のブログなどでリンクを貼って頂いています。ありがとうございます。その中でひときわ「ガレージ兵頭」という変なネーミングが目立っているように思います。他の方々は、やはり「CCIE」とか「ネットワーク」とか、そういうのが多いので。

当初はレースを応援してくれる方々へのレポートのために立ち上げたHPで、まさか世の中に私のページを発見する人がいると思わなかったので、つい実名を使ってしまってます。どこかでネーミングを変えないと、と思いながら面倒になってしまいました。この変なネーミングのまま、人生への挑戦を続けたいと思います。秋にはレースにも出るぞ!

| | コメント (2) | トラックバック (0)

2005年7月 7日 (木)

結線しました

sp_kizai 購入した機材と手持ちのものを合わせて結線してみました。このラック(?)は釣り用のものを流用しています。合格までの措置です。Playersの皆さん、ごめんなさい。でも釣りには行きます。

購入したRouterは基本的に2600シリーズです。CiscoのFeatureNavigatorで調べると、2600ではMPLS VPNなどが動作しません。3640以上が必要だと出力されます。しかし、私は2600で動作させています。2600でMPLSやVRF系のコマンドが入力できることは前々から知っていたのですが、実際に構成を組むまでは本当に動作するのか半信半疑でした。先日、IS-IS上でMBGPを動かしVRFを定義した上で、各VRF間でpingができることを確認しました。私はTELCO Feature を使用しています。他のFeatureでも動作するらしいのですが、皆さん、ご自分で確認してみてください。深夜3時まで夢中になって確認していました。こういうことしてる時って楽しいね。

| | コメント (2) | トラックバック (0)

2005年7月 6日 (水)

機材買いました

今までは会社の機材を借りたりしてSPの勉強をしてましたが、事情があり会社から借りたりできなくなりました(泣)。またR&SとSecurityの勉強をともに歩んできた2500たちはSPの勉強には使えません。MPLSが動かないので。そこで新しい機材を買っちゃいました。これで手持ちのRouterは16台になっちゃいました。一時期、PIXも所有していましたが、Securityの合格で手放してます。

画像はそのうちアップします。

皆さんは「電源大丈夫?」ってよく心配してくれるのですが、我が家はガレージ兼用ですので全然心配要りません。現在、機材たちはガレージ内で動作していますが、ガレージには溶接機やコンプレッサーなど大容量の機械があるので、ガレージは全然別系統で大きな電源容量を確保しています。

あぁ、そうそう、バイクのエンジンも組み上がったのでそちらもレポートしないといけないですね。

| | コメント (0) | トラックバック (0)

« 2005年6月 | トップページ | 2005年8月 »