« ラボ予約(ホテル編) | トップページ | 各受験地の昼食 »

2005年7月11日 (月)

PIXを経由するeBGP

PIXを経由するeBGPなんて何の意味があるのかどうか知らないが検証してみた。
読み飛ばして下さい。

<R1>
200.1.1.254
|
200.1.1.1(outside)
<PIX>
192.168.1.1(inside)
|
192.168.1.254 => 200.1.1.100でoutsideに公開
<R2>

***************各Routerで設定すること**************
<R1>
router bgp 100
no synchronization
network 150.1.1.0 mask 255.255.255.0
network 151.1.1.0 mask 255.255.255.0
network 210.1.1.0
neighbor 200.1.1.100 remote-as 200
neighbor 200.1.1.100 ebgp-multihop 2
neighbor 200.1.1.100 route-map SETNH in
!
route-map SETNH permit 10
set ip next-hop 200.1.1.100

<R2>
router bgp 200
no synchronization
network 135.1.1.0 mask 255.255.255.0
network 135.1.2.0 mask 255.255.255.0
network 199.1.1.0
neighbor 200.1.1.254 remote-as 100
neighbor 200.1.1.254 ebgp-multihop 2

<PIX>
access-list 100 permit tcp any any eq bgp
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 200.1.1.100 192.168.1.254 netmask 255.255.255.255 0 0
access-group 100 in interface outside
***************各Routerで設定すること**************

R1にてneighbor 200.1.1.100 route-map SETNH inを書かなければ<R1>はNextHopを解決できない(NextHopがPIXのInsideになるため)ため、RoutingTableに反映されない。
ebgp-multihopは、<R1>からみるとPeer先は同じネットワークなので不必要に思われるが、Debugをしてみるとnext-hopに到達できないのでRouteをDENYしているように見える。

02:08:10: BGP: 200.1.1.100 rcv UPDATE w/ attr: nexthop 192.168.1.254, origin i,
metric 0, path 200
02:08:10: BGP: 200.1.1.100 rcv UPDATE about 135.1.1.0/24 -- DENIED due to: non-c
onnected next-hop;
02:08:10: BGP: 200.1.1.100 rcv UPDATE about 135.1.2.0/24 -- DENIED due to: non-c
onnected next-hop;
02:08:10: BGP: 200.1.1.100 rcv UPDATE about 199.1.1.0/24 -- DENIED due to: non-c
onnected next-hop;

R1#sh ip bgp
   Network          Next Hop            Metric LocPrf Weight Path
*> 135.1.1.0/24     200.1.1.100              0             0 200 i
*> 135.1.2.0/24     200.1.1.100              0             0 200 i
*> 150.1.1.0/24     0.0.0.0                  0         32768 i
*> 151.1.1.0/24     0.0.0.0                  0         32768 i
*> 199.1.1.0        200.1.1.100              0             0 200 i
*> 210.1.1.0        0.0.0.0                  0         32768 i
R1#sh ip route
Gateway of last resort is 200.1.1.1 to network 0.0.0.0
C    200.1.1.0/24 is directly connected, Ethernet1
B    199.1.1.0/24 [20/0] via 200.1.1.100, 00:01:20
C    210.1.1.0/24 is directly connected, Loopback2
     151.1.0.0/24 is subnetted, 1 subnets
C       151.1.1.0 is directly connected, Loopback1
     150.1.0.0/24 is subnetted, 1 subnets
C       150.1.1.0 is directly connected, Loopback0
     135.1.0.0/24 is subnetted, 2 subnets
B       135.1.2.0 [20/0] via 200.1.1.100, 00:01:20
B       135.1.1.0 [20/0] via 200.1.1.100, 00:01:20
R*   0.0.0.0/0 [120/1] via 200.1.1.1, 00:00:18, Ethernet1

R2#sh ip bgp
   Network          Next Hop            Metric LocPrf Weight Path
*> 135.1.1.0/24     0.0.0.0                  0         32768 i
*> 135.1.2.0/24     0.0.0.0                  0         32768 i
*> 150.1.1.0/24     200.1.1.254              0             0 100 i
*> 151.1.1.0/24     200.1.1.254              0             0 100 i
*> 199.1.1.0        0.0.0.0                  0         32768 i
*> 210.1.1.0        200.1.1.254              0             0 100 i
R2#sh ip route
C    199.1.1.0/24 is directly connected, Loopback2
C    192.168.1.0/24 is directly connected, Ethernet1
B    210.1.1.0/24 [20/0] via 200.1.1.254, 00:00:51
     151.1.0.0/24 is subnetted, 1 subnets
B       151.1.1.0 [20/0] via 200.1.1.254, 00:00:51
     150.1.0.0/24 is subnetted, 1 subnets
B       150.1.1.0 [20/0] via 200.1.1.254, 00:00:51
     135.1.0.0/24 is subnetted, 2 subnets
C       135.1.2.0 is directly connected, Loopback1
C       135.1.1.0 is directly connected, Loopback0
R*   0.0.0.0/0 [120/1] via 192.168.1.1, 00:00:12, Ethernet1

|

« ラボ予約(ホテル編) | トップページ | 各受験地の昼食 »

コメント

コメントを書く



(ウェブ上には掲載しません)


コメントは記事投稿者が公開するまで表示されません。



トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/115947/4922495

この記事へのトラックバック一覧です: PIXを経由するeBGP:

« ラボ予約(ホテル編) | トップページ | 各受験地の昼食 »